CONFIGURING ETHERNET 0 INTERFACE
To configure Ethernet 0 interface, we must enter interface configuration mode
Router(config)# interface Ethernet 0
Router(config-if)#
Router(config-if)#
DESCRIPTION TO INTERFACE
To set description on interface, we must enter in interface configuration mode
Router(config-if)# description THIS IS ETHERNET 0 INTERFACE
ENABLE/DISABLE ETHERNET INTERFACE
To enable or disable Ethernet interface, enter the command no shut or shut respectively in interface configuration mode
Router(config)#interface fastethernet0/0
Router(config-if)#shut
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/0, changed state to down
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/0, changed state to up
Router(config-if)#
Router(config-if)#shut
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/0, changed state to down
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/0, changed state to up
Router(config-if)#
CONFIGURING IP ADDRESS ON ETHERNET INTERFACE
Considering Router 1, enter interface configuration mode and enter following commands to configure IP on Ethernet interfaces
ROUTER1(config)#interface fastEthernet 0/0
ROUTER1(config-if)#ip address 10.0.0.1 255.255.255.0
ROUTER1(config-if)#no shut
ROUTER1(config)#interface FastEthernet0/1
ROUTER1(config-if)#ip address 172.16.0.1 255.255.255.0
ROUTER1(config-if)#no shut
ROUTER1(config-if)#ip address 10.0.0.1 255.255.255.0
ROUTER1(config-if)#no shut
ROUTER1(config)#interface FastEthernet0/1
ROUTER1(config-if)#ip address 172.16.0.1 255.255.255.0
ROUTER1(config-if)#no shut
Verifying the connectivity with PC
Verifying Command
Router#show ip interface brief
Router#show interfaces fastEthernet 0/0
Router#show interfaces fastEthernet 0/0
CONFIGURING IP ADDRESS ON SERIAL INTERFACE
ROUTER1(config)#interface Serial0/0
ROUTER1(config-if)#ip address 10.0.0.1 255.255.255.252
ROUTER1(config-if)#clock rate 2000000 (Clock Rate will set only DCE interface)
ROUTER1(config-if)#ip address 10.0.0.1 255.255.255.252
ROUTER1(config-if)#clock rate 2000000 (Clock Rate will set only DCE interface)
ROUTER1(config-if)#no shut
ROUTER2(config)#interface Serial0/0
ROUTER2(config-if)#ip address 10.0.0.2 255.255.255.252
ROUTER2(config-if)#no shut
ROUTER2(config)#interface Serial0/0
ROUTER2(config-if)#ip address 10.0.0.2 255.255.255.252
ROUTER2(config-if)#no shut
Verifying Command
Router1#show controller se0/0
Router2#show controller se0/0
Router2#show controller se0/0